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1. Introduction

T-Mobile PC Telefon is a softphone designed specifically for business and enterprise users. It features 
the ability to make VoIP phone calls and to share presence (availability) information.

A system administrator in an enterprise can provision the application remotely (with or without DHCP), 
and automatically install the .msi package across an enterprise.

Standard Telephone Features

T-Mobile PC Telefon has all standard telephone features, including:

� Call display and Message Waiting Indicator (MWI).
� Speakerphone and Mute.
� Redial, Hold, Do Not Disturb
� Call history – list of received, missed, and dialed calls.
� Call transfer.
� Call record.
� Auto answer.
� Six-party audio conferencing.

Enhanced Features and Functions

T-Mobile PC Telefon also supports the following features and functions:

�Managed contact list – importing and exporting contacts between T-Mobile PC Telefon and other applications.
� Automatic detection and configuration of audio devices.
� Acoustic echo cancellation, automatic gain control, voice activity detection.
�Support for the following audio codecs:
AMR Wideband (G.722.2), Broadvoice-32, Broadvoice-32 FEC, DVI4, DVI4 Wideband, G.711aLaw,
G.711.uLaw, G.722, G.723, G.726, G.729, GSM, iLBC, L16 PCM Wideband, Speex, Speex FEC, 
Speex Wideband, Speex Wideband FEC.
� Automatic selection of the best codec based on the other party’s capability, the available bandwidth, 

and network conditions. T-Mobile PC Telefon switches the codec within a call in response to changing 
network conditions.
� SIP compliance to 3261 SIP standard.
� STUN and ICE NAT traversal. XTunnels for firewall traversal.
� Support for DTMF (RFC 2833, inband DTMF or SIP INFO messages).
� Availability in other languages.
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2. Installation and Setup

2.1 Getting Ready

Multimedia Device Requirements

T-Mobile PC Telefon requires both speakers and a microphone to make calls. 
Any of the following configurations are acceptable:

� External speakers and microphone
� Built-in speakers and microphone
� Dual-jack multimedia headset
� Bluetooth® multimedia headset
� USB multimedia headset
� USB phone.

Optimized Devices

T-Mobile PC Telefon is optimized to work with the following:

� Actiontec Internet Phone Wizard
� GN Netcom GN 8120 USB and GN Netcom 8110 USBXP
� Plantronics CS50-USB Wireless Office Headset System
� Polycom® Communicator C100S Wideband USB Speakerphone
� TigerJet RJ11 to USB Phone Adaptor (incorporating the Tiger560C)
� TigerJet USB Phone Set (incorporating the Tiger560C)
� Yealink USB-P1K USB hand phone
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2.2 Starting T-Mobile PC Telefon

If T-Mobile PC Telefon is not already running, start it as you would any other program: Use the Windows Start
menu or double-click the desktop icon. Either the Login window or the softphone itself appears. If the login 
window appears, enter the credentials provided by your system administrator.

2.3 Configuring T-Mobile PC Telefon

Read this section if your system administrator advises you that you must either configure T-Mobile PC Telefon
or complete the configuration.

(If your administrator advises you that configuration is already done, go to “Setting up a Contact List” on page 6.)

1. Choose File > Account Settings

2. Create or modify accounts as instructed by your administrator. See the following pages for details. 
When done, return to the Account Settings window and click Apply to register the accounts. 
Click OK when the Status column is “Ready”.
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2.4 Setting up a Contact List

Typically, you will want to create contacts in order to easily make phone calls. You can set up contacts 
in several ways:

� During a call that you place or receive, you can add the other party to your contact list. 
See “Handling an Established Call” on page 15.
� You can add addresses to the Contact list one by one. See “Adding a Contact” on page 24.
� You can import a contact list from a file or from another application. See “Importing Contacts” on page 26.

For general information on contacts, see “Contacts Tab” on page 23
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3. Using T-Mobile 
PC Telefon

3.1 Starting T-Mobile PC Telefon

If T-Mobile PC Telefon is not already running, start it as you would any other program: Use the Windows Start
menu or double-click the desktop icon. T-Mobile PC Telefon appears.

3.2 Shutting Down

To shut down T-Mobile PC Telefon, click File > Exit, or press Ctrl+Q. Note that clicking the Close button (X) 
on the softphone minimizes T-Mobile PC Telefon to the system tray; it does not exit.
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3.3 The Onscreen Softphone

The T-Mobile PC Telefon Menu

File

�My Profile. See page 32.
� Preferences. These settings control the way that you work with T-Mobile PC Telefon. See page 33.
� Account Settings. You will work with these settings only if advised to do so by your system administrator. 

See “Configuring T-Mobile PC Telefon” on page 32. 
� Sign Out. To log off and minimize T-Mobile PC Telefon to the system tray. If you click the T-Mobile PC Telefon

icon in the status bar, the Login screen appears.
� Exit. To shut down T-Mobile PC Telefon. You can also exit by pressing Ctrl+Q.
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T-Mobile 
PC Telefon menu. 
See below.

Call panel.
See page 9.

Address 
book panel.
See page 19.



View

Change how T-Mobile PC Telefon looks. See “Showing and Hiding Parts of the Softphone”.

Contacts

Lets you work with contacts. Everything in this menu except for import and export can also be performed 
directly in the Address Book panel. 

For information on these actions, including import and export, see page 23.

For information on managing blocked contacts, see “Privacy” on page 30.

Actions

Lists the actions that you can perform, depending on the current “state” of T-Mobile PC Telefon. For example,
if a contact is selected, it lists all the actions that can be performed on that contact.

If your enterprise has configured T-Mobile PC Telefon to display a Workgroup, you can view the Workgroup
from the Actions menu.

Help

Provides access to various service-related features.
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Showing and Hiding Parts of the Softphone

You can still receive calls when T-Mobile PC Telefon is hidden or minimized.

If you exit when T-Mobile PC Telefon is minimized or in Deskbar mode, T-Mobile PC Telefon will start next time
as minimized or in Deskbar mode.
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Close to System Tray

Show as Deskbar. See page 11

Close Call Panel (only Call entry
field will remain). Click again to
open.

Move Address Book to a separate window

Show/hide Address Book

Drag to resize

Show/hide Dial pad



The Deskbar

To display the softphone as a deskbar, click the Deskbar button.

The Deskbar provides a compact GUI for performing many T-Mobile PC Telefon actions. It is assumed that you
will work in this mode after you are quite familiar with T-Mobile PC Telefon and its features.

3.4 Placing a Call

You can contact someone using:

� A softphone address (for example, kpereira@domainA.com)
� A traditional phone number.

You can place a call when another call is already in progress. There is no limit to the number of calls you can
make, although eventually the quality of audio will degrade because of limitations on the computer. 
We recommend no more than six concurrent calls.
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Deskbar button

Restore to main window

Menu changes depending on whether 
there is an entry in the entry field

Call/end call button

Entry field



1. Place the call. See the table below. 

2. The new call is added to the Current Calls bar. You will hear a ringing tone while T-Mobile PC Telefon
attempts to make a connection.

3. Once the new call is established, switch between different calls by clicking the tab 
in the Current Calls bar.
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Other calls are on hold

Current calls bar

Call toolbar

Redial

Entry call field

Click to place a call

Filter
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How From the... Description

Keying

Drag-and-drop contact 
or previous call

Right-click a contact 
or previous call

Double-click a contact

Dialpad or computer 
keyboard

Contacts or History tab in
the Address Book panel

Contacts or History tab in
the Address Book panel

Contacts in the Address 
Boook panel

If another call is currently in progress, click       on
the Call toolbar. A new Call Entry area appears.
The current call is put on hold.

Enter the softphone address or number in the
Call entry field using the dialpad or the computer
keyboard.

For the name, you can enter the entire softphone
address (kpereira@domainA.com) or just the
name (kpereira).

As you type, a suggestion for completing the
entry may appear. Choose the suggestion or
keep typing.

To make a call, click the green Call button or
press Enter.

Drag an entry from the Contacts or History tab. The
call is placed immediately. (If the tab contains lots
of contacts, first use the       field to filter the list.)

Right-click an entry from the Contacts or History
tab and choose Call. The call is placed 
immediately. 

(If the tab contains lots of entries, first use the
field to filter the list.)

Contacts have a "double-click" action that makes
a phone call to one of the contact's number. 
Each contact can be configured separately 
for this action. See table 1 on page 25.
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Placing another Call

To place a new call (without hanging up on the current call), click the Start another Call button. In the Current
Calls bar, a tab appears for each separate call.

Hiding your Identity

You can hide your identity on a call, so that the other person will not see your ID on their phone.

Click Options > Hide my Number for this Call.      appears on the Call control bar for this call. Place the call 
in the usual way.

Double-click a previous
call

Redial

Dialing

History tab in the Address
Book panel

Redial button

Dialpad

Double-click an entry. The call is placed.

Click Actions and choose Redial. Or click 
the Redial button. 

The call is placed immediately.

If the dialpad is not visible, click the Show/Hide
dialpad button.
Click the numbers on the dialpad to enter the
phone number.
Click the green Call button or press Enter.

Start another 
call button



Your identity is hidden only for this call. 

Šifrování

The outgoing call may be encrypted, depending on your security settings.

� If an encrypted call is established, the encryption icon (      ) appears on the call display. This icon indicates
that the call is guaranteed to be secure between you and your proxy, and may or may not be secure beyond
that first hop. 
� If an unencrypted call is established, no encryption icon appears.
� If the call cannot be established with the specified security, the call will fail.

Ending a Call

Click the red End call button on the Call panel. Details of the call remain on the call display for a few seconds.

3.5 Handling an Incoming Call

T-Mobile PC Telefon must be running to answer incoming calls. (If T-Mobile PC Telefon is not running, incoming
calls may be directed to voicemail; check with your system administrator.)

T-Mobile PC Telefon rings and information about the incoming call appears in the Call entry field. In addition,
the Call Alert box appears, even if T-Mobile PC Telefon is minimized. For information on call alerts, see 
“Preferences – Alerts & Sounds” on page 34.
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The softphone address of the person calling you is displayed. The display name may also appear.

3.6 Handling an Established Call

While the call is in progress you can:

� Control the audio: use the speakerphone, mute the call, control volume.
� Record the call.
� Put the call on hold.
� Add the caller as a contact.
� Transfer the call. See the next page.
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Action From the... Description

Answer

Decline

Permanently block 
the caller

Call panel or Call Alert box

Call panel or Call Alert box

Options menu

Click Answer.

If you are on another call, that first call is 
automatically put on hold. You are now talking 
to the new caller.

Or press Enter (on the keyboard), if T-Mobile PC
Telefon is the active application.

Click Decline. There will be a busy signal. In
some networks, the call will be directed to voice-
mail (if you have this service).

Click the Options button and choose Block 
this person.



3.7 Transferring a Call

Quick Transfer

You can set up a list of phone numbers that calls can be transferred to. Then during a call, you can transfer to
any of these numbers by selecting from a list.
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Speakerphone (this button
only appears if your computer
has a speakerphone)

Volume control

You can do any of these even with
the call in progress. Many of these
actions are also buttons on the 
Call toolbar.

Conference call. See page 20.

Add the current
caller as a contact.
See “Adding a Contact
using an Existing 
Address” on page 24.

Hold

Place another call (this one will automatically be put on hold). See page 14.

Quick transfer. See page 17.

Mute

Record on/off



To set up the numbers:

1. Click File > Preferences from the menu. Display the Quick Transfer panel.

2. Enter as many numbers as you want. Use the Add, Edit and Remove buttons.

Set one of the numbers as the default and click OK.

To transfer a call, click the arrow on the Transfer button and click the number to transfer to. As soon as
the transfer is made (the other phone starts ringing), the call is disconnected at your end. 

Basic (Unattended) Transfer – Transfer this Call

You can transfer a call to any number, then hang up as soon as you have entered the number.

1. Click Options > Transfer this Call. The call display prompts for the number to transfer to.

2. Call the target (the person you are transfering the call to) by keying the number.

3. Click Transfer; the message Transfer Successful appears.Or click Cancel to continue the current call.
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Attended Transfer – Call then Transfer

You can first speak to the target (the person you are transferring the call to), then click Transfer to complete the
transfer.

1. Click Options > Call then Transfer. The first call is put on hold and a New call tab appears

2. Call the target in any of the normal ways.

3. When you are ready, click Transfer; the message Transfer Successful appears.

If the target does not want to take the call, simply end the call with that person. The first call is taken off hold.

3.8 Voicemail

If your service includes voicemail, then when you have voicemail messages, the word “new” appears beside 
the voicemail icon at the top of the phone. Click the icon to automatically connect to voicemail and listen to
your messages.
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3.9 Conference Calls

Starting a Conference Call

You can create a conference call starting from one existing call:

1. Click the Conference icon. T-Mobile PC Telefon enters “conference mode” and “Call a conference 
participant” appears on the call display.

2. Place the second call in one of these ways:

Right-click on a contact and choose Add to Conference Call.

Type a name or number. 
(Or to cancel the call, click the Cancel button.)
When the second callee answers, the call will automatically be added to the conference.

Or you can start a conference call using all the existing, separate calls:

1. Establish the calls. The calls can be incoming or outgoing.

2. Click Conference All.
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Conference icon Enter phone number for new participant



Managing the Conference

Adding More Participants

You can add more participants to an existing conference in any of these ways:

� Right-click on a contact and choose Add to Conference Call.
� From the tab that contains the conference, click the Conference icon. Place a call by typing a name 

or number. When the callee answers, the call will automatically be added to the conference.
� Place a separate outgoing call in the normal way (by clicking the New Call icon to display a new tab). 

When the call is established, click Conference All. All existing separate calls will be brought into the existing
conference.
� Accept one or more incoming calls. A separate call will be established for each call. Click Conference All. 

All existing separate calls will be brought into the existing conference. 
�Whenever you click Conference All, all current established calls are conferenced together; you cannot keep

any one call out of the conference.

Removing a Participant

To remove one call from the conference, click the down arrow beside a participant name and choose Separate
Call from Conference. The call becomes a separate call.
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Conference is now established

Click for actions for this participant



Disbanding the Conference

To break the conference into separate calls, click Options > Disband Conference.
To hang up on everyone, click the End button.

Suspending the Conference
To suspend the conference, click the Hold button. 

Audio Controls

Adjusting Volume
Use the speaker adjustment to adjust volume of the sound you are hearing. 

Mute
Click      on the dialpad to prevent the other parties from hearing you. The      icon appears on the call display.

Speakerphone
Click       on the dialpad to put the callers on the speaker phone. The       icon appears on the call display.
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4. Using the Address Book

The Address Book panel, which is divided into tabs, provides access to the following:

� Contacts.
� Call history. See page 29.

4.1 Contacts Tab

The Contacts tab displays your contacts and lets you specify multiple contact methods for them, including:

� Softphone address 
� Home phone number, business phone number, mobile phone number
� Fax number (this is provided for convenience; T-Mobile PC Telefon does not have any fax capability).
� E-mail
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Add a Contact Search field

Select more display options



You can identify one of these contacts as the primary contact method. 

Contacts are typically organized into groups. T-Mobile PC Telefon includes built-in groups: “Friends”, “Home”
and “Work”. You can add more groups, as desired.

Setting up Contacts

Adding a Contact
Click       , or right-click a group and choose Add Contact to Group. The Contact Profile dialog box appears. 
See the table on page 25.
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Table 1: Contact Profile Fields

Adding a Contact using an Existing Address

You can add a contact by capturing existing information:

� If you are on a phone call with a person who is not a contact, click the Add to Contacts button in the call
panel.
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Contact name Description

Contact name

Group

Ring tone

Contact Methods

Double-click action

Other fields

Only the “Display as” name is required. This is the name that will appear in
the call display and the Call Alert when this person phones you.

Either:

Choose one group.

Click Select Multiple Groups to add the new contact to more than 
one group.

Choose a ring tone for this contact, or use the preferred sound 
(which is defined in Preferences > Alerts). Click the arrow to play
the currently selected ring tone.

Enter as many contact methods as you want. E-mail and softphone entries
must have the format <name>@<domain>

Choose the desired method. This method will be used when you double-
click this contact. 

For example, if you choose “E-mail: kpereira@domainA.com”, then double-
clicking this contact will open an e-mail window using this address (rather
than any of the other addresses that exist for this contact).

Complete as desired.



� On the History tab, select an entry that is not a contact. Right-click and choose Add as Contact.

The Add a Contact dialog appears. 

If the user portion of the address matches the user portion of an existing address, the Update option is 
automatically selected. For example, if the address is kpereira@domainB.com and there is an existing contact
with an address of kpereira@domainA.com. Otherwise, the Create option is automatically selected.

Take the appropriate action:

� Create a new contact: Click Create. Change the display name, contact method, and group if desired. 
Click OK.
� Update an existing contact. Click Update. Choose a different contact, if necessary. Change the contact 

method and group, if desired. Click OK.

Importing Contacts

You can populate the T-Mobile PC Telefon contact list by importing from an external file or files. Your system 
administrator may have placed a file on a server for you to import. You can also import your own file or files, 
as many as required. The new contacts will be added to the existing contacts.

You can import a contact list from:

� A comma-separated file. Use this method to import from a Microsoft® Excel® file. You will first have to set up
the file; see below. 
� A vCard file (*.vcf file). A vCard is an electronic business card that is often attached to an e-mail.

1. From the main menu, click the Contacts menu and choose Import Contacts. 
The Import Contacts wizard starts. 

2. As soon as you click Finish on the wizard, the Contacts tab in T-Mobile PC Telefon is updated to show
the imported entries.

Setting up an Excel File for Import

1. Remove any introductory text or headings from the top of the file. (You can keep text at the end of the file;
it will be ignored during the import.)
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2. Insert a blank row as the first row, then insert the headings that T-Mobile PC Telefon will use to interpret
the meaning of each column. The columns can be in any order. The most popular headings are:

display-name

entry_id

given_name

surname

postal_address.
For a complete list of headings, see “Contact List Headings” on page 48.

3. Save the file as *.csv.

External Storage of the Contact List

Each time T-Mobile PC Telefon is started, the contact list is retrieved from the external storage. Each time 
a contact is added to the contact list, it is immediately copied to external storage. 

The list is always stored on the local computer. In addition, if you have access to a remote storage server, you
can configure T-Mobile PC Telefon so that the contact list is also stored remotely using XCap or WebDAV.

Exporting Contacts

You can export a contact list to a comma-separated file or a vcf file.

1. From the main menu, click the Contacts menu and choose Export Contacts. The Export Contacts wizard
starts. 

2. When you click Next, the export starts. The result is a new file of the specified type.
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Managing Contacts

Changing Contact Information

To change the information for a contact, right-click the contact and choose View Profile. The Contact Profile
dialog box appears (see page 24). Some of the changes you can make are:

� Change any contact details.
� Add, delete or change a contact method.
�Move a contact to another group by selecting a different group.
� Add an existing contact to more groups by selecting one or more extra groups.

Moving or Deleting a Contact

� To drag one or more contacts to a different group, select them and drag to the new group.
� To delete one or more contacts, select them, right-click, and choose Delete The contacts are removed from

this group.

Adding, Deleting or Renaming Groups

Select any group, right-click, and choose the appropriate menu item.

Contacts that have no group appear under “Ungrouped Contacts.” You can delete, but not rename, this group.

Using Contacts

Phone the person � Double-click the contact to start a phone call to the person.
� Drag the contact to the call display to start a phone call.
� Right-click and choose Call, then click the desired number.

Contact Flyout
Left-click on a contact to show the Contact flyout. This flyout shows all the contact methods set up for 
the contact and has icons you can click to perform an action that is valid for that contact method.
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Finding a Contact

If the contact list is long, use the        field to filter the contacts that are displayed. To clear the filter and display
all contacts again, click         .

4.2 History Tab
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Click an address or icon to perform the action

Display all calls

Missed calls

Received calls

Dialed calls

Outgoing call.
If answered,
Status shows
duration, if not
answered, Status
is “Dialed”

Incoming call that
was answered

Incoming missed
(Missed) or
blocked
(Rejected)



Managing the Lists of Calls

You can right-click on an entry in a list to:

� Delete the call.
� Delete all entries in this list.
� Block this person to control whether they can send you phone calls, or see your online availability. You can

change these privacy settings at any time; see page 30.
� View their profile if the entry is a contact.
� Add to contacts. Select Add as Contact to display the Add a Contact dialog box. Complete the dialog box and

click OK. For more information on the fields, see “Adding a Contact using an Existing Address” on page 25.

Phoning from a List

You can right-click on an entry in the Received or Dialed list to:

� Place a call to this person, using the contact method that was used for this call. You can also double-click 
to place a call.
� Place a call to this person and add them to a conference call that is in progress. For more information 

on conference calls, see “Conference Calls” on page 20.

4.3 Privacy

You can control how contacts and other people can contact you by phone, and you can control whether your
contacts can see your availability information (whether you are online, one the phone, and so on).

You can set up controls in advance or “on the fly” (as phone calls and presence requests come in).

Setting up Controls in Advance

To set up controls in advance, see “Preferences – Privacy” on page 36.

Setting up Controls “on the Fly”

On an Incoming Call

To block someone when they are phoning you, choose Options > Block this Person. 
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The call is declined, and this person is added to your Blocked List (see page 36). In addition, if the person 
is a contact, then “blocked” appears beside their name in the contact list. 

You will no longer see incoming calls from this person; they will automatically be declined. 

To later unblock this person, remove them from your Blocked List. Or, if the person is a contact, right-click their
name on the contact list and choose Unblock this Person.

From the Contact List or History List

Right-click on the name and choose Block this Person. The person will be added to your Blocked List 
(see page 36). The person will not be able to phone you, and will not see your availability information. 

To later unblock this person, right-click on the name and choose Unblock this Person.
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5. Configuring T-Mobile
PC Telefon

You can configure T-Mobile PC Telefon in several ways:

� Set up your personal profile. See below.
� Configure global behavior. See “Configuring Preferences” on page 33.
� Configure the account. See “Configuring Account” on page 46.

5.1 Configuring your Profile

To set up information about yourself, choose File > My Profile.
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5.2 Configuring Preferences

Choose File > Preferences. The Preferences window appears.

The Preferences panels let you control the way that you work with T-Mobile PC Telefon.

Preferences – Application

This panel lets you set your preferences for general GUI behavior.
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Preferences – Alerts & Sounds

This panel lets you control the Call Alerts box and lets you assign sounds. 

Enable alert displays

You can control whether the Call Alert 
box is displayed in different situations.
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Assigning Sounds

You can assign specific sounds to a variety of actions or “events”.

1. Select the Enable sounds check box and select the check boxes for each desired event, or clear the
Enable sounds check box to disable all sounds.

2. If enabling sounds, you can change the sound for each event: select the individual event. The value 
in Sound preference will change. Select the desired sound.

Keep in mind that you can also override any sound for an individual Contact; see page 24. 

You can import sounds; these will be added to the list of sounds you can choose from when assigning a sound
to an event.
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Preferences – Privacy

You can control how contacts and other people can contact you by phone.

36

Choose one
If you choose “Only
people on my contact list”,
then all contacts will be
able to contact you unless
they or their domain are in
the Blocked list (below).

This section is optional.
It lets you enter addresses
and domains that will be
prevented from contacting
you. You can add and
remove entries from the
blocked lists.
In addition, entries are
automatically added to
this list when you block
someone “on the fly”
(page 30)



Preferences – Quick Transfer

This panel lets you set up a list of phone numbers that calls can be transferred to. Then during a call, you can
transfer to any of these numbers by selecting from a list.

Enter as many numbers as you want. Use the Add, Edit and Remove buttons to edit the list. 
Set one of the numbers as the default.

See “Quick Transfer” on page 17 for information on using this feature.
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Preferences – Devices

T-Mobile PC Telefon automatically detects devices at each startup, and selects the most appropriate device 
for each purpose. If you do not like this selection, you can override it on this panel.

If you override a selection, it will apply the next time you start T-Mobile PC Telefon, unless the device is no
longer available, in which case T-Mobile PC Telefon will again select the device to use.
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Field Description

Headset Mode

Speaker 

Microphone 

Speakerphone Mode

Speaker 

Microphone

Change these fields only if you want to override the devices that  T-Mobile PC
Telefon automatically selected.

In both these fields, select the headset you are using.

The headset is the device that is usually used for audio out (the sound you
hear) and audio in (recording your voice). The only situation in which the 
headset is not used is when the Speaker Phone button on the dialpad is pressed.

Therefore, unless you will always be using T-Mobile PC Telefon in 
speakerphone mode, you must make a selection here.

Select the headset in both the Speaker device field and Microphone device field.

Change this field only if you want to override the devices that  T-Mobile PC 
Telefon automatically selected.

Make the appropriate choice:

� Select the device that you want to use for audio out (the sound you hear)
when the Speaker Phone button is pressed. Make sure you select a speaker
device (not the headset).

� Select None if you do not have a speaker phone. The Speaker Phone button
on the dialpad is disabled.

Change this field only if you want to override the devices that  T-Mobile PC 
Telefon automatically selected.
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Reduce background noise

Phone Ring Device

Device

Volume

Also ring PC speaker

Make the appropriate choice:

� Select the device that you want to use for audio in (recording your voice)
when the Speaker Phone button is pressed. 

It can be any microphone: it does not have to be the microphone on the 
device you specified as the speaker device. For example, it can be the 
microphone on your camera.

� Select None if you do not have a speaker phone. The Speaker Phone 
button on the dialpad is disabled.

Automatically attempts to remove background noise.

Typically on for the speakerphone.

Change this field only if you want to override the devices that  T-Mobile PC
Telefon automatically selected.

The device where you want to hear the phone ringing: the headset, 
the speakerphone, or none.

The volume of the ringer.

Click on or off, to suit your preference.



Preferences – Network
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Field Description

Network Connection
Speed

Preserve bandwidth

Select the type of network connection for your computer.

The sliders move to show the bitrate that will be used for sending 
and receiving. These rates are typical rates for the selected configuration.

If you know that your computer and network can handle a faster sending
speed, click Custom and move the slider.

It is recommended that you not change the receiving speed.

You will know that you have set the sending speed too high if the remote audio
is garbled.

When this feature is on, T-Mobile PC Telefon stops sending audio when 
you are not talking.

When this feature is off, T-Mobile PC Telefon always sends audio, which uses
more bandwidth but may result in better call quality.

Typically off. However, if you are using a slow (dial-up or ISDN) connection, 
you may want to turn it on. 



Preferences – Audio Codecs

Change the settings on this tab only if advised to do so by your system administrator.

Preferences – Quality of Service

Change the settings on this tab only if advised to do so by your system administrator.

Preferences – Contact Storage

Change the settings on this tab only if advised to do so by your system administrator.

Preferences – Diagnostics
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This panel lets you enable logging to files. Logging uses computer resources, so you should only enable it
when instructed by a customer support representative.

To set up logging:

1. Click Enable diagnostic logging. 
2. Set the logging level. 
3. Specify the folder where logs will be saved.
4. Click OK.

Activity on T-Mobile PC Telefon will be logged to .csv files in the specified folder. A new set of files is started
each time you log on. In order not to create large files when logging (which may create computer problems),
you must not remain logged on indefinitely when logging. You should occasionally exit and restart T-Mobile PC
Telefon.

If requested by a customer support representative, you can:
� Open the logging folder and then open a log file using a text editor. 
� E-mail the logs in the specified folder to customer support: Click Send logs to customer support. A dialog box

appears showing all the logs. Select files and click Open; the selected files are sent and the dialog box closes

You can delete log files from the specified folder as you would delete any file on your computer.
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Preferences – Advanced
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Field Description

Reduce echoes Turning this feature on improves sound quality. This feature is typically on.



5.3 Configuring Account

Account Settings Window

In general, you will work with the Account Settings window only when advised to do so by your system 
administrator; see “Configuring T-Mobile PC Telefon” on page 32.
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A. Application Hot Keys
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Function Keyboard Shortcut

Answer

Exit

Hang up

Hold

Mute

Enter

Ctrl+Q

Esc

Period

Spacebar



B. Contact List Headings

Following is a list of all the headings that are used in the T-Mobile PC Telefon contact list. This list can be useful
when formatting a contact list in order to import it into T-Mobile PC Telefon. For details, see “Importing 
Contacts” on page 26.
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uri

display-name

entry_id

given_name

surname

email_address

email_address2

email_address3

email_address4

email_address5

email_address6

sip_address

sip_address2

sip_address3

sip_address4

sip_address5

sip_address6

home_number

home_number2

home_number3

home_number4

home_number5

home_number6

business_number

business_number2

business_number3

business_number4

business_number5

business_number6

mobile_number

mobile_number2

mobile_number3

mobile_number4

mobile_number5

mobile_number6

fax_number

fax_number2

fax_number3

fax_number4

fax_number5

fax_number6

groups

comment

postal_address

default_address

default_address_type

sms_address s

ms_address2

sms_address3

sms_address4

sms_address5

sms_address6

custom_fields

custom_fields2

custom_fields3

custom_fields4

pres_subscription



C. Location of Files

System files get copied to the installation directory specified when installing T-Mobile PC Telefon. The default
installation directory is:

C:\Program Files\T-Mobile\PC Telefon

Data files are saved in the standard location for application data, as defined in Windows. 
This location is typically: 

C:\Documents and Settings\<user name>\Application Data\
T-Mobile Czech Republic a.s\T-Mobile PC Telefon\
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D. Other Ways to Run 
T-Mobile PC Telefon  

D.1 From the Command Line

You can start T-Mobile PC Telefon from a DOS prompt. You may need to add PCTelefon.exe to the PATH. 
Then type:

PCTelefon.exe

To start T-Mobile PC Telefon from a DOS prompt and immediately dial a number, type:

PCTelefon.exe -dial=sip:<number>
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E. Glossary
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AEC Acoustic echo cancellation. Processing of the audio or video signal to reduce the echo 
effect that can arise with a speakerphone or that can arise if the sound from the 
speakerphone or headphone leaks into the microphone.

AGC Automatic gain control. Processing of the audio or video signal to adjust the microphone
volume level so that the other party does not hear the distortion that might be caused by
too high a microphone input or too low volume (due to too low input level).

Codec The format by which an audio stream is compressed for transmission over networks.

Default account The SIP account that will be used when placing an outgoing call, if  T-Mobile PC Telefon
does not determine that another account should be used. T-Mobile PC Telefon uses the
dial plan to determine the account to use. Your system administrator will have identified
which account is the default.

Dial plan The rules that T-Mobile PC Telefon follows in order to interpret the softphone address or
phone number that the user has entered and to modify the number or address, 
as required, to ensure that the call will be placed successfully.

DTMF Dual-tone multi frequency. DTMF is the system that is used in interactive voice-response
menu systems such as the menu system for accessing voicemail messages. The DTMF
system allows the user to interact with the menu by pressing keys on a dialpad or keyboard.

IP Internet Protocol. A data-oriented protocol used for communicating data across a network.
IP is the most common protocol used on the internet.

IP address A unique number that devices use in order to identify and communicate with each other
on a computer network using the IP standard. 

Media In a VoIP phone call, the audio and video portion of the information in a call. Compare
to “Signaling”.

MWI Message Waiting Indicator. An indicator that there is a voicemail message for the owner 
of an account.

Proxy See SIP account.

PSTN Public Switch Telephone Network. The traditional land-line phone network.

RFC Request for Comment. A document that describes an aspect of an internet technology. 
An RFC may be a proposed, draft or full internet standard.

RTP Real-time Transport Protocol. A protocol for delivering the media portion of a data 
transmission over an IP network. SRTP is another media protocol.

Signaling In a VoIP phone call, the information in a call that deals with establishing and controlling
the connection, and managing the network. The non-signaling portion of the call is the
Media.
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SIP Session Initiation Protocol. The signaling protocol followed by T-Mobile PC Telefon for
handling phone calls. 

SIP account An account that provides the user the ability to make VoIP phone calls. The account en-
capsulates the rules and functions the user can access.

softphone address The address used to connect to a SIP endpoint. In other words, the “phone number” used
in a VoIP phone call. For example, sip:joseph@domainA.com.

SRTP Secure Real-time Transport Protocol. A protocol for delivering the media portion of a data
transmission over an IP network. SRTP is a secure protocol, which means that the media is
encrypted. RTP is another media protocol.

TCP Transmission Control Protocol. A transport protocol for delivering data over an IP network.
Other transport protocols are TLS and UDP.

TLS Transport Layer Security. A transport protocol for delivering data over an IP network. TLS is
a secure transport protocol, which means that all the data being transmitted (signaling and
media) is encrypted. Other transport protocols are TCP and UDP.

UDP User Datagram Protocol. A transport protocol for delivering data over an IP network. 
Other transport protocols are TCP and TLS.

URI Uniform Resource Identifier. A name or address that identifies a location on the world wide
web. A softphone address is a type of URI.

URL Uniform Resource Locator. A URI that both identifies a name or address and indicates how
to locate it. 

USB device Universal Serial Bus device. A device that follows a specific communications standard. 
A headset may be a “USB type” of headset. 

VAD Voice Activity Detection. A technology that detects if audio is a human voice 
or background noise.  T-Mobile PC Telefon includes a feature (Preserve bandwidth 
on the Network panel of the Preferences window) that controls whether audio is 
transmitted when VAD determines that no one is actually speaking.

vCard An electronic business card that is often attached to an e-mail. It often appears as 
a “signature” block that identifies the person, their title, and their business.

VoIP Voice over Internet Protocol. A variation of IP used for sending voice data over the internet,
in other words, used for making phone calls over the internet.

WAV Or WAVE. A file format standard for storing audio on PCs.



More information

Customer Centre T-Mobile
Tel. 4603 (ze sítě T-Mobile)

603 603 603
E-mail info@t-mobile.cz
Internet t-mobile.cz
T-Mobile Asistent 1183

The T-Mobile network means the electronic communications network 
operated by T-Mobile Czech Republic a.s.

mailto:info@t-mobile.cz
http://www.t-mobile.cz
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